In case you get this error:

Build script error, unsupported Gradle DSL method found: ‘instrumentTestCompile()’!
Possible causes could be:
– you are using Gradle version where the method is absent
– you didn’t apply Gradle plugin which provides the method
– or there is a mistake in a build script

instrumentTestCompile() was renamed to androidTestCompile() in the latest version of gradle plugin

Here is a guide http://tools.android.com/tech-docs/new-build-system/migrating_to_09
//DL