As you know there is native SIP support in 2.3. There’s SipManager class for it.

But it doesn’t work on Emulator! Both functions isApiSupported and isVoipSupported return false, SipManager.newInstance(this) returns null.

Application is installed without errors althought we have this line in manifest file:

<uses-feature
    android:name="android.hardware.sip.voip"
    android:required="true" />

Holy crap, Google! 🙂

//DL